{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8425 exists.","fix":"No fix has been published for CVE-2024-8425 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-8425 is a critical vulnerability in WP Swings WooCommerce Ultimate Gift Card, published on 28 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-8425 and fix it if it is affected.\n\nWhat it is: CVE-2024-8425 is a critical vulnerability in WP Swings WooCommerce Ultimate Gift Card, published on 28 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8425 exists.\n\nAffected product: WP Swings WooCommerce Ultimate Gift Card. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-8425/ (Markdown: https://insights.sbomify.com/CVE-2024-8425/index.md)","id":"CVE-2024-8425","markdown":"https://insights.sbomify.com/CVE-2024-8425/index.md","name":"CVE-2024-8425","record":{"aliases":["GHSA-7295-jw97-qrvm"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can upload arbitrary files via insufficient validation, potentially leading to remote code execution on WordPress sites using this plugin.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"woocommerce_ultimate_gift_card","vendor":"wpswings"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"The WooCommerce Ultimate Gift Card plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the 'mwb_wgm_preview_mail' and 'mwb_wgm_woocommerce_add_cart_item_data' functions in all versions up to, and including, 2.9.2. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible. Please note that this may have been patched on an older version than 2.9.2, however, we do not have access to older versions of the software to confirm when the patch was added. The only patched version we have confirmed is 2.9.3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2025-04-19","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":1,"refs":[{"date":"2025-04-19T02:23:15Z","kind":"github_poc","ref":"https://github.com/KTN1990/CVE-2024-8425","stars":2,"title":"The WooCommerce Ultimate Gift Card plugin for WordPress is vulnerable to arbitrary file uploads."},{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-8425.yaml","stars":null,"title":"WooCommerce Ultimate Gift Card ≤ 2.6.0 - Arbitrary File Upload"}],"tier":"weaponised"},"has_fix":null,"headline":"WooCommerce Ultimate Gift Card \u003c= 2.9.2 - Unauthenticated Arbitrary File Upload","id":"CVE-2024-8425","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"file_upload","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Pagelayer \u003c 1.8.8 - Admin+ Stored XSS","id":"CVE-2024-8426"},"packages":[],"prev":{"headline":"WatchGuard Endpoint Protection Privilege Escalation in PSANHost Enables Arbitrary File Delete as SYSTEM","id":"CVE-2024-8424"},"products":["WooCommerce Ultimate Gift Card"],"published":"2025-02-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["WP Swings"]},"summary":"Unauthenticated attackers can upload arbitrary files via insufficient validation, potentially leading to remote code execution on WordPress sites using this plugin.","url":"https://insights.sbomify.com/CVE-2024-8425/"}