CVE-2024-8494 Information disclosure in Elementor Website Builder Pro
Authenticated contributors can expose sensitive private, pending, and draft template content via a shortcode vulnerability in Elementor Pro.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-8494?
CVE-2024-8494 is a medium-severity vulnerability in https://elementor.com/ Elementor Website Builder Pro, published on 30 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Elementor Website Builder Pro plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.25.10 via the 'elementor-template' shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive data including the content of Private, Pending, and Draft Templates. The vulnerability was partially patched in version 3.24.4.
Weakness: CWE-200
Which versions are affected by CVE-2024-8494?
It affects 1 product.
Products include Elementor Website Builder.
How do I fix CVE-2024-8494?
No fix has been published for CVE-2024-8494 yet. Limit exposure of the affected software until one is available.
Is CVE-2024-8494 being exploited?
There is no known exploitation of CVE-2024-8494 in the wild and no public exploit code.
Other vulnerabilities in https://elementor.com/ Elementor Website Builder Pro
- CVE-2023-48777 WordPress Elementor plugin 3.3.0-3.18.1 - Arbitrary File Upload vulnerability
- CVE-2020-7109 Cross-site scripting in n/a
- CVE-2022-1329 Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution
- CVE-2024-24934 WordPress Elementor plugin <= 3.19.0 - Arbitrary File Deletion and Phar Deserialization vulnerability
- CVE-2023-0329 Elementor Website Builder < 3.12.2 - Admin+ SQLi
Sources
Also known as GHSA-c8w7-9g9r-2466.