{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-8494 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-8494 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-8494 is a medium-severity vulnerability in https://elementor.com/ Elementor Website Builder Pro, published on 30 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-8494 and fix it if it is affected.\n\nWhat it is: CVE-2024-8494 is a medium-severity vulnerability in https://elementor.com/ Elementor Website Builder Pro, published on 30 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-8494 in the wild and no public exploit code.\n\nAffected product: https://elementor.com/ Elementor Website Builder Pro. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-8494/ (Markdown: https://insights.sbomify.com/CVE-2024-8494/index.md)","id":"CVE-2024-8494","markdown":"https://insights.sbomify.com/CVE-2024-8494/index.md","name":"CVE-2024-8494","record":{"aliases":["GHSA-c8w7-9g9r-2466"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated contributors can expose sensitive private, pending, and draft template content via a shortcode vulnerability in Elementor Pro.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"website_builder","vendor":"elementor"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The Elementor Website Builder Pro plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.25.10 via the 'elementor-template' shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive data including the content of Private, Pending, and Draft Templates. The vulnerability was partially patched in version 3.24.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Information disclosure in Elementor Website Builder Pro","id":"CVE-2024-8494","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Null dereference in Connect Secure","id":"CVE-2024-8495"},"packages":[],"prev":{"headline":"The Events Calendar \u003c 6.6.4 - Admin+ Stored XSS","id":"CVE-2024-8493"},"products":["Elementor Website Builder Pro"],"published":"2025-01-30","related":[{"cvss_score":9.9,"headline":"WordPress Elementor plugin 3.3.0-3.18.1 - Arbitrary File Upload vulnerability","id":"CVE-2023-48777","kev_date_added":null,"published":"2024-03-26"},{"cvss_score":9.8,"headline":"Cross-site scripting in n/a","id":"CVE-2020-7109","kev_date_added":null,"published":"2020-01-22"},{"cvss_score":8.8,"headline":"Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution","id":"CVE-2022-1329","kev_date_added":null,"published":"2022-04-19"},{"cvss_score":8.5,"headline":"WordPress Elementor plugin \u003c= 3.19.0 - Arbitrary File Deletion and Phar Deserialization vulnerability","id":"CVE-2024-24934","kev_date_added":null,"published":"2024-05-17"},{"cvss_score":7.2,"headline":"Elementor Website Builder \u003c 3.12.2 - Admin+ SQLi","id":"CVE-2023-0329","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":6.5,"headline":"WordPress Elementor plugin \u003c= 3.25.10 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-54444","kev_date_added":null,"published":"2025-02-25"},{"cvss_score":6.5,"headline":"WordPress Elementor plugin \u003c= 3.16.4 - Auth. Arbitrary Attachment Read vulnerability","id":"CVE-2023-47504","kev_date_added":null,"published":"2024-04-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["https://elementor.com/"]},"summary":"Authenticated contributors can expose sensitive private, pending, and draft template content via a shortcode vulnerability in Elementor Pro.","url":"https://insights.sbomify.com/CVE-2024-8494/"}