CVE-2024-8521 Wavelog Live QSO qso index cross site scripting

Medium 6.9 Published Updated

Remote attackers can inject malicious scripts via the manual argument in the Live QSO index, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-8521?

CVE-2024-8521 is a medium-severity cross-site scripting vulnerability in Wavelog, published on 7 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability, which was classified as problematic, was found in Wavelog up to 1.8.0. Affected is the function index of the file /qso of the component Live QSO. The manipulation of the argument manual leads to cross site scripting. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.8.1 is able to address this issue. The patch is identified as b31002cec6b71ab5f738881806bb546430ec692e. It is recommended to upgrade the affected component.

Weakness: CWE-79

Which versions are affected by CVE-2024-8521?

It affects 1 product.

Products include Wavelog Wavelog.

How do I fix CVE-2024-8521?

No fix has been published for CVE-2024-8521 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-8521 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8521 exists.

Sources

Also known as GHSA-wff2-3734-8hcr.

Is CVE-2024-8521 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free