{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8521 exists.","fix":"No fix has been published for CVE-2024-8521 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-8521 is a medium-severity cross-site scripting vulnerability in Wavelog, published on 7 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-8521 and fix it if it is affected.\n\nWhat it is: CVE-2024-8521 is a medium-severity cross-site scripting vulnerability in Wavelog, published on 7 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8521 exists.\n\nAffected product: Wavelog. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-8521/ (Markdown: https://insights.sbomify.com/CVE-2024-8521/index.md)","id":"CVE-2024-8521","markdown":"https://insights.sbomify.com/CVE-2024-8521/index.md","name":"CVE-2024-8521","record":{"aliases":["GHSA-wff2-3734-8hcr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Wavelog web application","requires_auth":"none","summary":"Remote attackers can inject malicious scripts via the manual argument in the Live QSO index, potentially compromising user sessions.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"wavelog","vendor":"wavelog"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, was found in Wavelog up to 1.8.0. Affected is the function index of the file /qso of the component Live QSO. The manipulation of the argument manual leads to cross site scripting. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.8.1 is able to address this issue. The patch is identified as b31002cec6b71ab5f738881806bb546430ec692e. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Wavelog Live QSO qso index cross site scripting","id":"CVE-2024-8521","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":7,"next":{"headline":"LearnPress – WordPress LMS Plugin \u003c= 4.2.7 - Unauthenticated SQL Injection via 'c_only_fields'","id":"CVE-2024-8522"},"packages":[],"prev":{"headline":"Ultimate Member \u003c= 2.8.6 - Cross-Site Request Forgery to Membership Status Change","id":"CVE-2024-8520"},"products":["Wavelog"],"published":"2024-09-07","related":[{"cvss_score":7.3,"headline":"SQL injection in n/a","id":"CVE-2024-48249","kev_date_added":null,"published":"2024-10-14"},{"cvss_score":7.3,"headline":"SQL injection in n/a","id":"CVE-2024-48251","kev_date_added":null,"published":"2024-10-14"},{"cvss_score":7.3,"headline":"SQL injection in n/a","id":"CVE-2024-48257","kev_date_added":null,"published":"2024-10-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-09","vendors":["n/a"]},"summary":"Remote attackers can inject malicious scripts via the manual argument in the Live QSO index, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2024-8521/"}