# CVE-2024-8615: WP JobSearch <= 2.6.7 - Unauthenticated Arbitrary File Upload

> Unauthenticated attackers can upload arbitrary files to the server, potentially leading to remote code execution.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Nov 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-32mh-mpq7-pqcr

## What is CVE-2024-8615?

CVE-2024-8615 is a critical vulnerability in eyecix JobSearch WP Job Board, published on 6 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The JobSearch WP Job Board plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the jobsearch_location_load_excel_file_callback() function in all versions up to, and including, 2.6.7. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2024-8615?

It affects 1 product.


Products: Eyecix Jobsearch Wp Job Board.

## How do I fix CVE-2024-8615?

No fix has been published for CVE-2024-8615 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-8615 being exploited?

There is no known exploitation of CVE-2024-8615 in the wild and no public exploit code.

## Other vulnerabilities in eyecix JobSearch WP Job Board

- [CVE-2024-8614](https://insights.sbomify.com/CVE-2024-8614/): WP JobSearch <= 2.6.7 - Authenticated (Subscriber+) Arbitrary File Upload (critical 9.9)
- [CVE-2024-47636](https://insights.sbomify.com/CVE-2024-47636/): WordPress WP JobSearch plugin <= 2.5.9 - PHP Object Injection vulnerability (critical 9.8)
- [CVE-2024-43931](https://insights.sbomify.com/CVE-2024-43931/): WordPress JobSearch WP Job Board WordPress Plugin plugin <= 2.5.3 - PHP Object Injection vulnerability (critical 9.8)
- [CVE-2021-4361](https://insights.sbomify.com/CVE-2021-4361/): JobSearch WP Job Board <= 1.8.1 - Missing Authorization to Arbitrary Options Update (high 8.8)
- [CVE-2023-6584](https://insights.sbomify.com/CVE-2023-6584/): JobSearch WP Job Board < 2.3.4 - Authentication Bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8615 and fix it if it is affected.

What it is: CVE-2024-8615 is a critical vulnerability in eyecix JobSearch WP Job Board, published on 6 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-8615 in the wild and no public exploit code.

Affected product: eyecix JobSearch WP Job Board. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8615/ (Markdown: https://insights.sbomify.com/CVE-2024-8615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8615
- OSV: https://osv.dev/vulnerability/CVE-2024-8615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8615/
Summaries are generated and may contain mistakes; the official description above is the record.
