CVE-2024-8631 Privilege Defined With Unsafe Actions in GitLab
A user with the Admin Group Member custom role can escalate privileges to include other custom roles in GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-8631?
CVE-2024-8631 is a medium-severity vulnerability in Gitlab Gitlab, published on 12 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A privilege escalation issue has been discovered in GitLab EE affecting all versions starting from 16.6 prior to 17.1.7, from 17.2 prior to 17.2.5, and from 17.3 prior to 17.3.2. A user assigned the Admin Group Member custom role could have escalated their privileges to include other custom roles.
Weakness: CWE-267
Which versions are affected by CVE-2024-8631?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.6.0 | 17.1.7, 17.2.5, 17.3.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-8631?
Upgrade gitlab to a fixed version for your release line: 17.1.7, 17.2.5 or 17.3.2.
Is CVE-2024-8631 being exploited?
There is no known exploitation of CVE-2024-8631 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-8631, GHSA-pvq4-gmpq-27p3.