CVE-2024-8635 Server-Side Request Forgery (SSRF) in GitLab

High 7.7 Published Updated

An attacker can exploit a custom Maven Dependency Proxy URL to perform Server-Side Request Forgery against internal resources in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-8635?

CVE-2024-8635 is a high-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 12 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A server-side request forgery issue has been discovered in GitLab EE affecting all versions starting from 16.8 prior to 17.1.7, from 17.2 prior to 17.2.5, and from 17.3 prior to 17.3.2. It was possible for an attacker to make requests to internal resources using a custom Maven Dependency Proxy URL

Weakness: CWE-918

Which versions are affected by CVE-2024-8635?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.8.017.1.7, 17.2.5, 17.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-8635?

Upgrade gitlab to a fixed version for your release line: 17.1.7, 17.2.5 or 17.3.2.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2024-8635 being exploited?

There is no known exploitation of CVE-2024-8635 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-8635, GHSA-859x-xr5x-c9x2.

Is CVE-2024-8635 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free