CVE-2024-8640 Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab
Attackers can inject commands into a connected Cube server in GitLab EE, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-8640?
CVE-2024-8640 is a high-severity command injection vulnerability in Gitlab Gitlab, published on 12 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab EE affecting all versions starting from 16.11 prior to 17.1.7, from 17.2 prior to 17.2.5, and from 17.3 prior to 17.3.2. Due to incomplete input filtering, it was possible to inject commands into a connected Cube server.
Weakness: CWE-77
Which versions are affected by CVE-2024-8640?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.11.0 | 17.1.7, 17.2.5, 17.3.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-8640?
Upgrade gitlab to a fixed version for your release line: 17.1.7, 17.2.5 or 17.3.2.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2024-8640 being exploited?
There is no known exploitation of CVE-2024-8640 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-8640, GHSA-4v6w-vxg7-j28q.