# CVE-2024-8640: Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab

> Attackers can inject commands into a connected Cube server in GitLab EE, potentially leading to code execution.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2024
- **Updated:** 13 Sep 2024
- **Also known as:** BIT-gitlab-2024-8640, GHSA-4v6w-vxg7-j28q

## What is CVE-2024-8640?

CVE-2024-8640 is a high-severity command injection vulnerability in Gitlab Gitlab, published on 12 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue has been discovered in GitLab EE affecting all versions starting from 16.11 prior to 17.1.7, from 17.2 prior to 17.2.5, and from 17.3 prior to 17.3.2. Due to incomplete input filtering, it was possible to inject commands into a connected Cube server.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-8640?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 16.11.0 | 17.1.7, 17.2.5, 17.3.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-8640?

Upgrade gitlab to a fixed version for your release line: 17.1.7, 17.2.5 or 17.3.2.

## Is CVE-2024-8640 being exploited?

There is no known exploitation of CVE-2024-8640 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8640 and fix it if it is affected.

What it is: CVE-2024-8640 is a high-severity command injection vulnerability in Gitlab Gitlab, published on 12 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-8640 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 16.11.0; fixed in 17.1.7, 17.2.5, 17.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8640/ (Markdown: https://insights.sbomify.com/CVE-2024-8640/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8640
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8640
- OSV: https://osv.dev/vulnerability/CVE-2024-8640

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8640/
Summaries are generated and may contain mistakes; the official description above is the record.
