{"answers":{"affected":"2 open source packages ship an affected version, including org.eclipse.edc:transfer-data-plane. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8642 exists.","fix":"Upgrade org.eclipse.edc:transfer-data-plane to 0.9.0 or later.","what":"CVE-2024-8642 is a medium-severity authentication bypass vulnerability in Eclipse EDC Connector, published on 11 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-8642 and fix it if it is affected.\n\nWhat it is: CVE-2024-8642 is a medium-severity authentication bypass vulnerability in Eclipse EDC Connector, published on 11 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8642 exists.\n\nAffected packages and fixed versions:\n- org.eclipse.edc:transfer-data-plane (Maven): affected from 0.5.0; fixed in 0.9.0\n- org.eclipse.edc:transfer-data-plane (Maven): affected from 0.5.0; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-8642/ (Markdown: https://insights.sbomify.com/CVE-2024-8642/index.md)","id":"CVE-2024-8642","markdown":"https://insights.sbomify.com/CVE-2024-8642/index.md","name":"CVE-2024-8642","record":{"aliases":["GHSA-8259-2x72-2gvc"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Eclipse EDC Connector","requires_auth":"high_privilege","summary":"Attackers can bypass token expiration checks in Eclipse EDC if specific dataplane modules are enabled, allowing unauthorized access to consumer pull transfers.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"eclipse","cpe":[{"product":"eclipse_dataspace_components","vendor":"eclipse"}],"cvss":{"score":5,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/RE:L/U:Green","version":"4.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"},{"id":"CWE-305","name":"Authentication Bypass by Primary Weakness"},{"id":"CWE-303","name":"Incorrect Implementation of Authentication Algorithm"}],"description":"In Eclipse Dataspace Components, from version 0.5.0 and before version 0.9.0, the ConsumerPullTransferTokenValidationApiController does not check for token validity (expiry, not-before, issuance date), which can allow an attacker to bypass the check for token expiration. The issue requires to have a dataplane configured to support http proxy consumer pull AND include the module \"transfer-data-plane\". The affected code was marked deprecated from the version 0.6.0 in favour of Dataplane Signaling. In 0.9.0 the vulnerable code has been removed.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Eclipse EDC: Consumer pull transfer token validation checks not applied","id":"CVE-2024-8642","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"Session Hijacking in Oceanic Software's ValeApp","id":"CVE-2024-8643"},"packages":[{"ecosystem":"Maven","fixed":["0.9.0"],"introduced":["0.5.0"],"last_affected":[],"package":"org.eclipse.edc:transfer-data-plane","purl":null,"source":"GHSA-8259-2x72-2gvc"},{"ecosystem":"Maven","fixed":["0.9.0"],"introduced":["0.5.0"],"last_affected":[],"package":"org.eclipse.edc:transfer-data-plane","purl":"pkg:maven/org.eclipse.edc/transfer-data-plane","source":"GHSA-8259-2x72-2gvc"}],"prev":{"headline":"Privilege Context Switching Error in GitLab","id":"CVE-2024-8641"},"products":["Eclipse EDC Connector"],"published":"2024-09-11","related":[{"cvss_score":5.3,"headline":"EDC DataSetResolver policy filtering missing","id":"CVE-2024-9202","kev_date_added":null,"published":"2024-09-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-11","vendors":["Eclipse Foundation"]},"summary":"Attackers can bypass token expiration checks in Eclipse EDC if specific dataplane modules are enabled, allowing unauthorized access to consumer pull transfers.","url":"https://insights.sbomify.com/CVE-2024-8642/"}