# CVE-2024-8642: Eclipse EDC: Consumer pull transfer token validation checks not applied

> Attackers can bypass token expiration checks in Eclipse EDC if specific dataplane modules are enabled, allowing unauthorized access to consumer pull transfers.

- **Severity:** Medium 5.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2024
- **Updated:** 11 Sep 2024
- **Also known as:** GHSA-8259-2x72-2gvc

## What is CVE-2024-8642?

CVE-2024-8642 is a medium-severity authentication bypass vulnerability in Eclipse EDC Connector, published on 11 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In Eclipse Dataspace Components, from version 0.5.0 and before version 0.9.0, the ConsumerPullTransferTokenValidationApiController does not check for token validity (expiry, not-before, issuance date), which can allow an attacker to bypass the check for token expiration. The issue requires to have a dataplane configured to support http proxy consumer pull AND include the module "transfer-data-plane". The affected code was marked deprecated from the version 0.6.0 in favour of Dataplane Signaling. In 0.9.0 the vulnerable code has been removed.

Weakness: CWE-287 (Improper Authentication), CWE-305 (Authentication Bypass by Primary Weakness), CWE-303 (Incorrect Implementation of Authentication Algorithm)

## Which versions are affected by CVE-2024-8642?

2 open source packages ship an affected version, including org.eclipse.edc:transfer-data-plane. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.edc:transfer-data-plane` | Maven | From 0.5.0 | 0.9.0 |
| `org.eclipse.edc:transfer-data-plane` | Maven | From 0.5.0 | 0.9.0 |

Products: Eclipse Eclipse Dataspace Components.

## How do I fix CVE-2024-8642?

Upgrade org.eclipse.edc:transfer-data-plane to 0.9.0 or later.

## Is CVE-2024-8642 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8642 exists.

## Other vulnerabilities in Eclipse EDC Connector

- [CVE-2024-9202](https://insights.sbomify.com/CVE-2024-9202/): EDC DataSetResolver policy filtering missing (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8642 and fix it if it is affected.

What it is: CVE-2024-8642 is a medium-severity authentication bypass vulnerability in Eclipse EDC Connector, published on 11 Sep 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8642 exists.

Affected packages and fixed versions:
- org.eclipse.edc:transfer-data-plane (Maven): affected from 0.5.0; fixed in 0.9.0
- org.eclipse.edc:transfer-data-plane (Maven): affected from 0.5.0; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8642/ (Markdown: https://insights.sbomify.com/CVE-2024-8642/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8642
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8642
- OSV: https://osv.dev/vulnerability/CVE-2024-8642

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8642/
Summaries are generated and may contain mistakes; the official description above is the record.
