CVE-2024-8648 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Medium 6.1 Published Updated

An attacker can inject malicious JavaScript into GitLab Analytics Dashboards via a crafted URL, potentially leading to code execution or account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-8648?

CVE-2024-8648 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 14 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 16 before 17.3.7, 17.4 before 17.4.4, and 17.5 before 17.5.2. The vulnerability could allow an attacker to inject malicious JavaScript code in Analytics Dashboards through a specially crafted URL.

Weakness: CWE-79

Which versions are affected by CVE-2024-8648?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.0.017.3.7, 17.4.4, 17.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-8648?

Upgrade gitlab to a fixed version for your release line: 17.3.7, 17.4.4 or 17.5.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-8648 being exploited?

There is no known exploitation of CVE-2024-8648 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-8648, GHSA-p27q-qvwx-7mg5, UBUNTU-CVE-2024-8648.

Is CVE-2024-8648 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free