CVE-2024-8661 Concrete CMS version 9.0.0 to 9.3.3 and below 8.5.19 are vulnerable to Stored XSS in the "Next&Previous Nav" block
A rogue administrator can inject malicious scripts into the Next&Previous Nav block, leading to stored XSS execution in victim browsers.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-8661?
CVE-2024-8661 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 16 Sep 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Concrete CMS versions 9.0.0 to 9.3.3 and below 8.5.19 are vulnerable to Stored XSS in the "Next&Previous Nav" block. A rogue administrator could add a malicious payload by executing it in the browsers of targeted users. The Concrete CMS Security Team gave this vulnerability a CVSS v4 score of 4.6 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N Since the "Next&Previous Nav" block output was not sufficiently sanitized, the malicious payload could be executed in the browsers of targeted users. Thanks, Chu Quoc Khanh for reporting.
Weakness: CWE-79
Which versions are affected by CVE-2024-8661?
4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/concrete5 Packagist | All versions | 8.5.19 |
concrete5/concrete5 Packagist | All versions | 8.5.19 |
concrete5/concrete5 Packagist | From 9.0.0 | 9.3.4 |
concrete5/concrete5 Packagist | From 9.0.0 | 9.3.4 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2024-8661?
Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.19 or 9.3.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-8661 being exploited?
There is no known exploitation of CVE-2024-8661 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-xmxj-v2q8-8qx6.