CVE-2024-8756 Quform - WordPress Form Builder <= 2.20.0 - Unauthenticated Sensitive Information Exposure

Medium 5.3 Published Updated

Unauthenticated attackers can extract sensitive user data from uploaded files in the Quform WordPress plugin, requiring manual file cleanup after patching.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-8756?

CVE-2024-8756 is a medium-severity vulnerability in ThemeCatcher Quform - WordPress Form Builder, published on 9 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Quform - WordPress Form Builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.20.0 via the 'saveUploadedFile' function. This makes it possible for unauthenticated attackers to extract sensitive data, such as Personally Identifiable Information, from files uploaded by users. Files uploaded via forms created before version 2.21.0 will remain vulnerable to exposure after upgrading. To fully patch the plugin, site administrators should download any previously uploaded files, delete previously existing files and forms, and create the forms again after upgrading to version 2.21.0.

Weakness: CWE-200

Which versions are affected by CVE-2024-8756?

How do I fix CVE-2024-8756?

No fix has been published for CVE-2024-8756 yet. Limit exposure of the affected software until one is available.

Is CVE-2024-8756 being exploited?

There is no known exploitation of CVE-2024-8756 in the wild and no public exploit code.

Sources

Also known as GHSA-g7pq-m585-vmf6.

Is CVE-2024-8756 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free