{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-8756 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-8756 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-8756 is a medium-severity vulnerability in ThemeCatcher Quform - WordPress Form Builder, published on 9 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-8756 and fix it if it is affected.\n\nWhat it is: CVE-2024-8756 is a medium-severity vulnerability in ThemeCatcher Quform - WordPress Form Builder, published on 9 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-8756 in the wild and no public exploit code.\n\nAffected product: ThemeCatcher Quform - WordPress Form Builder. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-8756/ (Markdown: https://insights.sbomify.com/CVE-2024-8756/index.md)","id":"CVE-2024-8756","markdown":"https://insights.sbomify.com/CVE-2024-8756/index.md","name":"CVE-2024-8756","record":{"aliases":["GHSA-g7pq-m585-vmf6"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress form plugin","requires_auth":"none","summary":"Unauthenticated attackers can extract sensitive user data from uploaded files in the Quform WordPress plugin, requiring manual file cleanup after patching.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The Quform - WordPress Form Builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.20.0 via the 'saveUploadedFile' function. This makes it possible for unauthenticated attackers to extract sensitive data, such as Personally Identifiable Information, from files uploaded by users. Files uploaded via forms created before version 2.21.0 will remain vulnerable to exposure after upgrading. To fully patch the plugin, site administrators should download any previously uploaded files, delete previously existing files and forms, and create the forms again after upgrading to version 2.21.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Quform - WordPress Form Builder \u003c= 2.20.0 - Unauthenticated Sensitive Information Exposure","id":"CVE-2024-8756","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Boost Your Blog's Engagement with WP Post Author \u003c= 3.8.1 - Authenticated (Administrator+) SQL Injection","id":"CVE-2024-8757"},"packages":[],"prev":{"headline":"Improper Input Validation vulnerability of Authenticated User in Progress LoadMaster allows : OS Command Injection.","id":"CVE-2024-8755"},"products":["Quform - WordPress Form Builder"],"published":"2024-11-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["ThemeCatcher"]},"summary":"Unauthenticated attackers can extract sensitive user data from uploaded files in the Quform WordPress plugin, requiring manual file cleanup after patching.","url":"https://insights.sbomify.com/CVE-2024-8756/"}