# CVE-2024-8756: Quform - WordPress Form Builder <= 2.20.0 - Unauthenticated Sensitive Information Exposure

> Unauthenticated attackers can extract sensitive user data from uploaded files in the Quform WordPress plugin, requiring manual file cleanup after patching.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Nov 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-g7pq-m585-vmf6

## What is CVE-2024-8756?

CVE-2024-8756 is a medium-severity vulnerability in ThemeCatcher Quform - WordPress Form Builder, published on 9 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Quform - WordPress Form Builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.20.0 via the 'saveUploadedFile' function. This makes it possible for unauthenticated attackers to extract sensitive data, such as Personally Identifiable Information, from files uploaded by users. Files uploaded via forms created before version 2.21.0 will remain vulnerable to exposure after upgrading. To fully patch the plugin, site administrators should download any previously uploaded files, delete previously existing files and forms, and create the forms again after upgrading to version 2.21.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-8756?


## How do I fix CVE-2024-8756?

No fix has been published for CVE-2024-8756 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-8756 being exploited?

There is no known exploitation of CVE-2024-8756 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8756 and fix it if it is affected.

What it is: CVE-2024-8756 is a medium-severity vulnerability in ThemeCatcher Quform - WordPress Form Builder, published on 9 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-8756 in the wild and no public exploit code.

Affected product: ThemeCatcher Quform - WordPress Form Builder. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8756/ (Markdown: https://insights.sbomify.com/CVE-2024-8756/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8756
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8756
- OSV: https://osv.dev/vulnerability/CVE-2024-8756

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8756/
Summaries are generated and may contain mistakes; the official description above is the record.
