{"answers":{"affected":"3 open source packages ship an affected version, including vllm.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8768 exists.","fix":"Upgrade vllm to 0.5.5 or later.","what":"CVE-2024-8768 is a high-severity denial of service vulnerability in Red Hat Enterprise Linux AI (RHEL AI), published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-8768 and fix it if it is affected.\n\nWhat it is: CVE-2024-8768 is a high-severity denial of service vulnerability in Red Hat Enterprise Linux AI (RHEL AI), published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8768 exists.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected all versions; fixed in 0.5.5\n- vllm (PyPI): affected all versions; fixed in 0.5.5\n- vllm (PyPI): affected all versions; fixed in 0.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-8768/ (Markdown: https://insights.sbomify.com/CVE-2024-8768/index.md)","id":"CVE-2024-8768","markdown":"https://insights.sbomify.com/CVE-2024-8768/index.md","name":"CVE-2024-8768","record":{"aliases":["GHSA-w2r7-9579-27hf","PYSEC-2026-2024"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"vLLM library","requires_auth":"none","summary":"An attacker can crash the vLLM API server by sending a completions request with an empty prompt, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-617","name":"Reachable Assertion"}],"description":"A flaw was found in the vLLM library. A completions API request with an empty prompt will crash the vLLM API server, resulting in a denial of service.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Vllm: a completions api request with an empty prompt will crash the vllm api server.","id":"CVE-2024-8768","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":4,"next":{"headline":"Arbitrary File Deletion via Relative Path Traversal in aimhubio/aim","id":"CVE-2024-8769"},"packages":[{"ecosystem":"PyPI","fixed":["0.5.5"],"introduced":["0"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-w2r7-9579-27hf"},{"ecosystem":"PyPI","fixed":["0.5.5"],"introduced":["0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-w2r7-9579-27hf"},{"ecosystem":"PyPI","fixed":["0.5.5"],"introduced":["0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-2024"}],"prev":{"headline":"Privilege escalation in Acronis Backup extension for Plesk","id":"CVE-2024-8767"},"products":["Red Hat Enterprise Linux AI (RHEL AI)"],"published":"2024-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-20","vendors":["Red Hat"]},"summary":"An attacker can crash the vLLM API server by sending a completions request with an empty prompt, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2024-8768/"}