# CVE-2024-8768: Vllm: a completions api request with an empty prompt will crash the vllm api server.

> An attacker can crash the vLLM API server by sending a completions request with an empty prompt, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2024
- **Updated:** 20 Nov 2025
- **Also known as:** GHSA-w2r7-9579-27hf, PYSEC-2026-2024

## What is CVE-2024-8768?

CVE-2024-8768 is a high-severity denial of service vulnerability in Red Hat Enterprise Linux AI (RHEL AI), published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in the vLLM library. A completions API request with an empty prompt will crash the vLLM API server, resulting in a denial of service.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2024-8768?

3 open source packages ship an affected version, including vllm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.5.5 |
| `vllm` | PyPI | All versions | 0.5.5 |
| `vllm` | PyPI | All versions | 0.5.5 |

## How do I fix CVE-2024-8768?

Upgrade vllm to 0.5.5 or later.

## Is CVE-2024-8768 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8768 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8768 and fix it if it is affected.

What it is: CVE-2024-8768 is a high-severity denial of service vulnerability in Red Hat Enterprise Linux AI (RHEL AI), published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8768 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.5.5
- vllm (PyPI): affected all versions; fixed in 0.5.5
- vllm (PyPI): affected all versions; fixed in 0.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8768/ (Markdown: https://insights.sbomify.com/CVE-2024-8768/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8768
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8768
- OSV: https://osv.dev/vulnerability/CVE-2024-8768

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8768/
Summaries are generated and may contain mistakes; the official description above is the record.
