CVE-2024-8810 Privilege escalation in Enterprise Server

High 8.7 Published Updated

A malicious GitHub App could self-escalate permissions to write access, allowing data modification without administrator approval.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-8810?

CVE-2024-8810 is a high-severity vulnerability in Github Enterprise Server, published on 7 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A GitHub App installed in organizations could upgrade some permissions from read to write access without approval from an organization administrator. An attacker would require an account with administrator access to install a malicious GitHub App. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.14.1, 3.13.4, 3.12.9, 3.11.15, and 3.10.17. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-269

Which versions are affected by CVE-2024-8810?

It affects 1 product.

Products include Github Enterprise Server.

How do I fix CVE-2024-8810?

No fix has been published for CVE-2024-8810 yet. Limit exposure of the affected software until one is available.

Is CVE-2024-8810 being exploited?

There is no known exploitation of CVE-2024-8810 in the wild and no public exploit code.

All Github Enterprise Server vulnerabilities

Sources

Also known as GHSA-q9j8-8r5f-j3wm.

Is CVE-2024-8810 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free