CVE-2024-8925 Erroneous parsing of multipart form data
Attackers can manipulate multipart form data parsing to exclude legitimate data, causing erroneous application behavior in PHP applications.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-8925?
CVE-2024-8925 is a low-severity vulnerability in Php Php, published on 8 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, erroneous parsing of multipart form data contained in an HTTP POST request could lead to legitimate data not being processed. This could lead to malicious attacker able to control part of the submitted data being able to exclude portion of other data, potentially leading to erroneous application behavior.
Weakness: CWE-444
Which versions are affected by CVE-2024-8925?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
php Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
php-min Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
Products include Php Php.
How do I fix CVE-2024-8925?
Upgrade libphp to a fixed version for your release line: 8.1.30, 8.2.24 or 8.3.12.
Is CVE-2024-8925 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8925 exists.
Other vulnerabilities in Php Php
Sources
Also known as AZL-50153, AZL-50166, BELL-CVE-2024-8925, BIT-libphp-2024-8925, BIT-php-2024-8925, BIT-php-min-2024-8925 and 12 more.