{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8925 exists.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.30, 8.2.24 or 8.3.12.","what":"CVE-2024-8925 is a low-severity vulnerability in Php Php, published on 8 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-8925 and fix it if it is affected.\n\nWhat it is: CVE-2024-8925 is a low-severity vulnerability in Php Php, published on 8 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8925 exists.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12\n- php (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12\n- php-min (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-8925/ (Markdown: https://insights.sbomify.com/CVE-2024-8925/index.md)","id":"CVE-2024-8925","markdown":"https://insights.sbomify.com/CVE-2024-8925/index.md","name":"CVE-2024-8925","record":{"aliases":["AZL-50153","AZL-50166","BELL-CVE-2024-8925","BIT-libphp-2024-8925","BIT-php-2024-8925","BIT-php-min-2024-8925","CLEANSTART-2026-CK30216","CLSA-2024-1730139582","CLSA-2024-1730141462","CLSA-2024-1730226852","CLSA-2024-1730227099","CLSA-2024-1730227233","CLSA-2024-1730369205","CLSA-2024-1730369378","DEBIAN-CVE-2024-8925","ECHO-1077-189e-4048","GHSA-9pqp-7h25-4f32","UBUNTU-CVE-2024-8925"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","other"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP scripting language","requires_auth":"low_privilege","summary":"Attackers can manipulate multipart form data parsing to exclude legitimate data, causing erroneous application behavior in PHP applications.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, erroneous parsing of multipart form data contained in an HTTP POST request could lead to legitimate data not being processed. This could lead to malicious attacker able to control part of the submitted data being able to exclude portion of other data, potentially leading to erroneous application behavior.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Erroneous parsing of multipart form data","id":"CVE-2024-8925","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"other","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"PHP CGI Parameter Injection Vulnerability (CVE-2024-4577 bypass)","id":"CVE-2024-8926"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.30","8.2.24","8.3.12"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2024-8925"},{"ecosystem":"Bitnami","fixed":["8.1.30","8.2.24","8.3.12"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2024-8925"},{"ecosystem":"Bitnami","fixed":["8.1.30","8.2.24","8.3.12"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2024-8925"}],"prev":{"headline":"Unauthenticated Blind SQL Injection in Core Platform","id":"CVE-2024-8924"},"products":["PHP"],"published":"2024-10-08","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["PHP Group"]},"summary":"Attackers can manipulate multipart form data parsing to exclude legitimate data, causing erroneous application behavior in PHP applications.","url":"https://insights.sbomify.com/CVE-2024-8925/"}