# CVE-2024-8925: Erroneous parsing of multipart form data

> Attackers can manipulate multipart form data parsing to exclude legitimate data, causing erroneous application behavior in PHP applications.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-50153, AZL-50166, BELL-CVE-2024-8925, BIT-libphp-2024-8925, BIT-php-2024-8925, BIT-php-min-2024-8925, CLEANSTART-2026-CK30216, CLSA-2024-1730139582, CLSA-2024-1730141462, CLSA-2024-1730226852, CLSA-2024-1730227099, CLSA-2024-1730227233, CLSA-2024-1730369205, CLSA-2024-1730369378, DEBIAN-CVE-2024-8925, ECHO-1077-189e-4048, GHSA-9pqp-7h25-4f32, UBUNTU-CVE-2024-8925

## What is CVE-2024-8925?

CVE-2024-8925 is a low-severity vulnerability in Php Php, published on 8 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, erroneous parsing of multipart form data contained in an HTTP POST request could lead to legitimate data not being processed. This could lead to malicious attacker able to control part of the submitted data being able to exclude portion of other data, potentially leading to erroneous application behavior.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2024-8925?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
| `php` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
| `php-min` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |

Products: Php Php.

## How do I fix CVE-2024-8925?

Upgrade libphp to a fixed version for your release line: 8.1.30, 8.2.24 or 8.3.12.

## Is CVE-2024-8925 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8925 exists.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8925 and fix it if it is affected.

What it is: CVE-2024-8925 is a low-severity vulnerability in Php Php, published on 8 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8925 exists.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12
- php (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12
- php-min (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8925/ (Markdown: https://insights.sbomify.com/CVE-2024-8925/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8925
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8925
- OSV: https://osv.dev/vulnerability/CVE-2024-8925

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8925/
Summaries are generated and may contain mistakes; the official description above is the record.
