# CVE-2024-8926: PHP CGI Parameter Injection Vulnerability (CVE-2024-4577 bypass)

> Attackers can bypass security fixes to inject commands via PHP CGI in specific Windows codepage configurations, enabling arbitrary code execution and source code disclosure.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2024
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-libphp-2024-8926, BIT-php-2024-8926, BIT-php-min-2024-8926, CLEANSTART-2026-YW89455, DEBIAN-CVE-2024-8926, ECHO-23f7-5807-f11c, GHSA-p99j-rfp4-xqvq

## What is CVE-2024-8926?

CVE-2024-8926 is a high-severity command injection vulnerability in Php Php, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, when using a certain non-standard configurations of Windows codepages, the fixes for  CVE-2024-4577 https://github.com/advisories/GHSA-vxpp-6299-mxw3  may still be bypassed and the same command injection related to Windows "Best Fit" codepage behavior can be achieved. This may allow a malicious user to pass options to PHP binary being run, and thus reveal the source code of scripts, run arbitrary PHP code on the server, etc.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2024-8926?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
| `php` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
| `php-min` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |

Products: Php Php.

## How do I fix CVE-2024-8926?

Upgrade libphp to a fixed version for your release line: 8.1.30, 8.2.24 or 8.3.12.

## Is CVE-2024-8926 being exploited?

There is no known exploitation of CVE-2024-8926 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8926 and fix it if it is affected.

What it is: CVE-2024-8926 is a high-severity command injection vulnerability in Php Php, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-8926 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12
- php (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12
- php-min (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8926/ (Markdown: https://insights.sbomify.com/CVE-2024-8926/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8926
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8926
- OSV: https://osv.dev/vulnerability/CVE-2024-8926

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8926/
Summaries are generated and may contain mistakes; the official description above is the record.
