{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-8927 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.30, 8.2.24 or 8.3.12.","what":"CVE-2024-8927 is a high-severity vulnerability in Php Php, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-8927 and fix it if it is affected.\n\nWhat it is: CVE-2024-8927 is a high-severity vulnerability in Php Php, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-8927 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12\n- php (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12\n- php-min (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-8927/ (Markdown: https://insights.sbomify.com/CVE-2024-8927/index.md)","id":"CVE-2024-8927","markdown":"https://insights.sbomify.com/CVE-2024-8927/index.md","name":"CVE-2024-8927","record":{"aliases":["AZL-50132","AZL-50164","BELL-CVE-2024-8927","BIT-libphp-2024-8927","BIT-php-2024-8927","BIT-php-min-2024-8927","CLEANSTART-2026-QY88672","CLSA-2024-1729626489","CLSA-2024-1729626893","CLSA-2024-1729627812","CLSA-2024-1729628500","CLSA-2024-1729628764","DEBIAN-CVE-2024-8927","ECHO-1153-4040-6ca1","GHSA-94p6-54jq-9mwp","UBUNTU-CVE-2024-8927"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP scripting language","requires_auth":"none","summary":"Attackers can bypass CGI security restrictions via environment variable collision, potentially leading to arbitrary file inclusion and code execution in specific PHP configurations.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-1220","name":"Insufficient Granularity of Access Control"}],"description":"In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, HTTP_REDIRECT_STATUS variable is used to check whether or not CGI binary is being run by the HTTP server. However, in certain scenarios, the content of this variable can be controlled by the request submitter via HTTP headers, which can lead to cgi.force_redirect option not being correctly applied. In certain configurations this may lead to arbitrary file inclusion in PHP.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"cgi.force_redirect configuration is bypassable due to the environment variable collision","id":"CVE-2024-8927","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"security_feature_bypass","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Leak partial content of the heap through heap buffer over-read in mysqlnd","id":"CVE-2024-8929"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.30","8.2.24","8.3.12"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2024-8927"},{"ecosystem":"Bitnami","fixed":["8.1.30","8.2.24","8.3.12"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2024-8927"},{"ecosystem":"Bitnami","fixed":["8.1.30","8.2.24","8.3.12"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2024-8927"}],"prev":{"headline":"PHP CGI Parameter Injection Vulnerability (CVE-2024-4577 bypass)","id":"CVE-2024-8926"},"products":["PHP"],"published":"2024-10-08","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["PHP Group"]},"summary":"Attackers can bypass CGI security restrictions via environment variable collision, potentially leading to arbitrary file inclusion and code execution in specific PHP configurations.","url":"https://insights.sbomify.com/CVE-2024-8927/"}