# CVE-2024-8927: cgi.force_redirect configuration is bypassable due to the environment variable collision

> Attackers can bypass CGI security restrictions via environment variable collision, potentially leading to arbitrary file inclusion and code execution in specific PHP configurations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-50132, AZL-50164, BELL-CVE-2024-8927, BIT-libphp-2024-8927, BIT-php-2024-8927, BIT-php-min-2024-8927, CLEANSTART-2026-QY88672, CLSA-2024-1729626489, CLSA-2024-1729626893, CLSA-2024-1729627812, CLSA-2024-1729628500, CLSA-2024-1729628764, DEBIAN-CVE-2024-8927, ECHO-1153-4040-6ca1, GHSA-94p6-54jq-9mwp, UBUNTU-CVE-2024-8927

## What is CVE-2024-8927?

CVE-2024-8927 is a high-severity vulnerability in Php Php, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, HTTP_REDIRECT_STATUS variable is used to check whether or not CGI binary is being run by the HTTP server. However, in certain scenarios, the content of this variable can be controlled by the request submitter via HTTP headers, which can lead to cgi.force_redirect option not being correctly applied. In certain configurations this may lead to arbitrary file inclusion in PHP.

Weakness: CWE-1220 (Insufficient Granularity of Access Control)

## Which versions are affected by CVE-2024-8927?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
| `php` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
| `php-min` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |

Products: Php Php.

## How do I fix CVE-2024-8927?

Upgrade libphp to a fixed version for your release line: 8.1.30, 8.2.24 or 8.3.12.

## Is CVE-2024-8927 being exploited?

There is no known exploitation of CVE-2024-8927 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8927 and fix it if it is affected.

What it is: CVE-2024-8927 is a high-severity vulnerability in Php Php, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-8927 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12
- php (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12
- php-min (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8927/ (Markdown: https://insights.sbomify.com/CVE-2024-8927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8927
- OSV: https://osv.dev/vulnerability/CVE-2024-8927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8927/
Summaries are generated and may contain mistakes; the official description above is the record.
