CVE-2024-8929 Leak partial content of the heap through heap buffer over-read in mysqlnd
A hostile MySQL server can trigger a heap buffer over-read in PHP's mysqlnd, leaking heap memory contents including data from other requests.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-8929?
CVE-2024-8929 is a medium-severity vulnerability in Php Php, published on 22 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, a hostile MySQL server can cause the client to disclose the content of its heap containing data from other SQL requests and possible other data belonging to different users of the same server.
Which versions are affected by CVE-2024-8929?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | All versions | 8.1.31, 8.2.24, 8.3.14 |
php Bitnami | All versions | 8.1.31, 8.2.24, 8.3.14 |
php-min Bitnami | All versions | 8.1.31, 8.2.24, 8.3.14 |
Products include Php Php.
How do I fix CVE-2024-8929?
Upgrade libphp to a fixed version for your release line: 8.1.31, 8.2.24 or 8.3.14.
Is CVE-2024-8929 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8929 exists.
Other vulnerabilities in Php Php
Sources
Also known as AZL-53685, AZL-53885, BELL-CVE-2024-8929, BIT-libphp-2024-8929, BIT-php-2024-8929, BIT-php-min-2024-8929 and 13 more.