{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8929 exists.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.31, 8.2.24 or 8.3.14.","what":"CVE-2024-8929 is a medium-severity vulnerability in Php Php, published on 22 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-8929 and fix it if it is affected.\n\nWhat it is: CVE-2024-8929 is a medium-severity vulnerability in Php Php, published on 22 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8929 exists.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.31, 8.2.24, 8.3.14\n- php (Bitnami): affected all versions; fixed in 8.1.31, 8.2.24, 8.3.14\n- php-min (Bitnami): affected all versions; fixed in 8.1.31, 8.2.24, 8.3.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-8929/ (Markdown: https://insights.sbomify.com/CVE-2024-8929/index.md)","id":"CVE-2024-8929","markdown":"https://insights.sbomify.com/CVE-2024-8929/index.md","name":"CVE-2024-8929","record":{"aliases":["AZL-53685","AZL-53885","BELL-CVE-2024-8929","BIT-libphp-2024-8929","BIT-php-2024-8929","BIT-php-min-2024-8929","CLSA-2024-1735130624","CLSA-2025-1738695324","CLSA-2025-1738696117","CLSA-2025-1739812360","CLSA-2025-1740242864","CLSA-2025-1757946824","DEBIAN-CVE-2024-8929","ECHO-0adc-6bfc-6cab","GHSA-h35g-vwh6-m678","MINI-j5fr-2vq8-m3h6","MINI-mvq4-xxw6-qwpm","MINI-rrhp-x7c8-mfwr","UBUNTU-CVE-2024-8929"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PHP mysqlnd library","requires_auth":"low_privilege","summary":"A hostile MySQL server can trigger a heap buffer over-read in PHP's mysqlnd, leaking heap memory contents including data from other requests.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"},{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, a hostile MySQL server can cause the client to disclose the content of its heap containing data from other SQL requests and possible other data belonging to different users of the same server.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Leak partial content of the heap through heap buffer over-read in mysqlnd","id":"CVE-2024-8929","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"information_disclosure","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"OOB access in ldap_escape","id":"CVE-2024-8932"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.31","8.2.24","8.3.14"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2024-8929"},{"ecosystem":"Bitnami","fixed":["8.1.31","8.2.24","8.3.14"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2024-8929"},{"ecosystem":"Bitnami","fixed":["8.1.31","8.2.24","8.3.14"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2024-8929"}],"prev":{"headline":"cgi.force_redirect configuration is bypassable due to the environment variable collision","id":"CVE-2024-8927"},"products":["PHP"],"published":"2024-11-22","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["PHP Group"]},"summary":"A hostile MySQL server can trigger a heap buffer over-read in PHP's mysqlnd, leaking heap memory contents including data from other requests.","url":"https://insights.sbomify.com/CVE-2024-8929/"}