# CVE-2024-8929: Leak partial content of the heap through heap buffer over-read in mysqlnd

> A hostile MySQL server can trigger a heap buffer over-read in PHP's mysqlnd, leaking heap memory contents including data from other requests.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Nov 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-53685, AZL-53885, BELL-CVE-2024-8929, BIT-libphp-2024-8929, BIT-php-2024-8929, BIT-php-min-2024-8929, CLSA-2024-1735130624, CLSA-2025-1738695324, CLSA-2025-1738696117, CLSA-2025-1739812360, CLSA-2025-1740242864, CLSA-2025-1757946824, DEBIAN-CVE-2024-8929, ECHO-0adc-6bfc-6cab, GHSA-h35g-vwh6-m678, MINI-j5fr-2vq8-m3h6, MINI-mvq4-xxw6-qwpm, MINI-rrhp-x7c8-mfwr, UBUNTU-CVE-2024-8929

## What is CVE-2024-8929?

CVE-2024-8929 is a medium-severity vulnerability in Php Php, published on 22 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, a hostile MySQL server can cause the client to disclose the content of its heap containing data from other SQL requests and possible other data belonging to different users of the same server.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2024-8929?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.31, 8.2.24, 8.3.14 |
| `php` | Bitnami | All versions | 8.1.31, 8.2.24, 8.3.14 |
| `php-min` | Bitnami | All versions | 8.1.31, 8.2.24, 8.3.14 |

Products: Php Php.

## How do I fix CVE-2024-8929?

Upgrade libphp to a fixed version for your release line: 8.1.31, 8.2.24 or 8.3.14.

## Is CVE-2024-8929 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8929 exists.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8929 and fix it if it is affected.

What it is: CVE-2024-8929 is a medium-severity vulnerability in Php Php, published on 22 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8929 exists.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.31, 8.2.24, 8.3.14
- php (Bitnami): affected all versions; fixed in 8.1.31, 8.2.24, 8.3.14
- php-min (Bitnami): affected all versions; fixed in 8.1.31, 8.2.24, 8.3.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8929/ (Markdown: https://insights.sbomify.com/CVE-2024-8929/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8929
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8929
- OSV: https://osv.dev/vulnerability/CVE-2024-8929

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8929/
Summaries are generated and may contain mistakes; the official description above is the record.
