CVE-2024-8943 LatePoint <= 5.0.12 - Authentication Bypass
Unauthenticated attackers can log in as any user, including administrators, if the WordPress user integration setting is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-8943?
CVE-2024-8943 is a critical authentication bypass vulnerability in LatePoint Plugin, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The LatePoint plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 5.0.12. This is due to insufficient verification on the user being supplied during the booking customer step. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the user id. Note that logging in as a WordPress user is only possible if the "Use WordPress users as customers" setting is enabled, which is disabled by default. The vulnerability is partially patched in version 5.0.12 and fully patched in version 5.0.13.
Which versions are affected by CVE-2024-8943?
It affects 1 product.
Products include Latepoint Latepoint.
How do I fix CVE-2024-8943?
No fix has been published for CVE-2024-8943 yet. Limit exposure of the affected software until one is available.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2024-8943 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8943 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in LatePoint Plugin
- CVE-2024-8911 LatePoint <= 5.0.11 - Unauthenticated Arbitrary User Password Change via SQL Injection
- CVE-2024-2472 LatePoint Plugin <= 4.9.9 - Missing Authorization and Sensitive Information Exposure via IDOR
- CVE-2024-43945 WordPress LatePoint plugin <= 4.9.91 - Cross Site Request Forgery (CSRF) vulnerability
- CVE-2024-43992 WordPress LatePoint plugin <= 4.9.91 - Cross Site Scripting (XSS) vulnerability
Sources
Also known as GHSA-jwc3-mm8j-j745.