{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8943 exists.","fix":"No fix has been published for CVE-2024-8943 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-8943 is a critical authentication bypass vulnerability in LatePoint Plugin, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-8943 and fix it if it is affected.\n\nWhat it is: CVE-2024-8943 is a critical authentication bypass vulnerability in LatePoint Plugin, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8943 exists.\n\nAffected product: LatePoint Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-8943/ (Markdown: https://insights.sbomify.com/CVE-2024-8943/index.md)","id":"CVE-2024-8943","markdown":"https://insights.sbomify.com/CVE-2024-8943/index.md","name":"CVE-2024-8943","record":{"aliases":["GHSA-jwc3-mm8j-j745"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can log in as any user, including administrators, if the WordPress user integration setting is enabled.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"latepoint","vendor":"latepoint"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"},{"id":"CWE-288","name":"Authentication Bypass Using an Alternate Path or Channel"}],"description":"The LatePoint plugin for WordPress is vulnerable to authentication bypass in versions up to, and including,  5.0.12. This is due to insufficient verification on the user being supplied during the booking customer step. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the user id. Note that logging in as a WordPress user is only possible if the \"Use WordPress users as customers\" setting is enabled, which is disabled by default. The vulnerability is partially patched in version 5.0.12 and fully patched in version 5.0.13.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-8943.yaml","stars":null,"title":"LatePoint \u003c= 5.0.12 - Authentication Bypass"}],"tier":"weaponised"},"has_fix":null,"headline":"LatePoint \u003c= 5.0.12 - Authentication Bypass","id":"CVE-2024-8943","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"code-projects Hospital Management System check_availability.php sql injection","id":"CVE-2024-8944"},"packages":[],"prev":{"headline":"Cross-site Scripting vulnerability on Scriptcase","id":"CVE-2024-8942"},"products":["LatePoint Plugin"],"published":"2024-10-08","related":[{"cvss_score":9.8,"headline":"LatePoint \u003c= 5.0.11 - Unauthenticated Arbitrary User Password Change via SQL Injection","id":"CVE-2024-8911","kev_date_added":null,"published":"2024-10-08"},{"cvss_score":9.1,"headline":"LatePoint Plugin \u003c= 4.9.9 - Missing Authorization and Sensitive Information Exposure via IDOR","id":"CVE-2024-2472","kev_date_added":null,"published":"2024-06-14"},{"cvss_score":6.5,"headline":"WordPress LatePoint plugin \u003c= 4.9.91 - Cross Site Request Forgery (CSRF) vulnerability","id":"CVE-2024-43945","kev_date_added":null,"published":"2024-10-21"},{"cvss_score":6.5,"headline":"WordPress LatePoint plugin \u003c= 4.9.91 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-43992","kev_date_added":null,"published":"2024-09-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["latepoint"]},"summary":"Unauthenticated attackers can log in as any user, including administrators, if the WordPress user integration setting is enabled.","url":"https://insights.sbomify.com/CVE-2024-8943/"}