# CVE-2024-8943: LatePoint <= 5.0.12 - Authentication Bypass

> Unauthenticated attackers can log in as any user, including administrators, if the WordPress user integration setting is enabled.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Oct 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-jwc3-mm8j-j745

## What is CVE-2024-8943?

CVE-2024-8943 is a critical authentication bypass vulnerability in LatePoint Plugin, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The LatePoint plugin for WordPress is vulnerable to authentication bypass in versions up to, and including,  5.0.12. This is due to insufficient verification on the user being supplied during the booking customer step. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the user id. Note that logging in as a WordPress user is only possible if the "Use WordPress users as customers" setting is enabled, which is disabled by default. The vulnerability is partially patched in version 5.0.12 and fully patched in version 5.0.13.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2024-8943?

It affects 1 product.


Products: Latepoint Latepoint.

## How do I fix CVE-2024-8943?

No fix has been published for CVE-2024-8943 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-8943 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8943 exists.

Public exploit code:

- LatePoint <= 5.0.12 - Authentication Bypass (nuclei): http/cves/2024/CVE-2024-8943.yaml

## Other vulnerabilities in LatePoint Plugin

- [CVE-2024-8911](https://insights.sbomify.com/CVE-2024-8911/): LatePoint <= 5.0.11 - Unauthenticated Arbitrary User Password Change via SQL Injection (critical 9.8)
- [CVE-2024-2472](https://insights.sbomify.com/CVE-2024-2472/): LatePoint Plugin <= 4.9.9 - Missing Authorization and Sensitive Information Exposure via IDOR (critical 9.1)
- [CVE-2024-43945](https://insights.sbomify.com/CVE-2024-43945/): WordPress LatePoint plugin <= 4.9.91 - Cross Site Request Forgery (CSRF) vulnerability (medium 6.5)
- [CVE-2024-43992](https://insights.sbomify.com/CVE-2024-43992/): WordPress LatePoint plugin <= 4.9.91 - Cross Site Scripting (XSS) vulnerability (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8943 and fix it if it is affected.

What it is: CVE-2024-8943 is a critical authentication bypass vulnerability in LatePoint Plugin, published on 8 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8943 exists.

Affected product: LatePoint Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8943/ (Markdown: https://insights.sbomify.com/CVE-2024-8943/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8943
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8943
- OSV: https://osv.dev/vulnerability/CVE-2024-8943

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8943/
Summaries are generated and may contain mistakes; the official description above is the record.
