# CVE-2024-8947: MicroPython objarray.c use after free

> A use-after-free vulnerability in MicroPython's objarray component allows remote attackers to potentially execute code or cause denial of service via crafted bytes manipulation.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2024
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2024-8947, GHSA-pwwp-3q7j-9mx8, PYSEC-2024-92, PYSEC-2024-94, UBUNTU-CVE-2024-8947, openSUSE-SU-2026:10704-1

## What is CVE-2024-8947?

CVE-2024-8947 is a medium-severity use after free vulnerability in MicroPython, published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in MicroPython 1.22.2. It has been declared as critical. Affected by this vulnerability is an unknown functionality of the file py/objarray.c. The manipulation leads to use after free. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 1.23.0 is able to address this issue. The identifier of the patch is 4bed614e707c0644c06e117f848fa12605c711cd. It is recommended to upgrade the affected component. In micropython objarray component, when a bytes object is resized and copied into itself, it may reference memory that has already been freed.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2024-8947?

6 open source packages ship an affected version, including micropython-copy and micropython-io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `micropython-copy` | PyPI | All versions | None |
| `micropython-copy` | PyPI | All versions to 3.3.3.post3 | None |
| `micropython-copy` | PyPI | All versions to 3.3.3.post3 | None |
| `micropython-io` | PyPI | All versions | None |
| `micropython-io` | PyPI | All versions to 0.1 | None |
| `micropython-io` | PyPI | All versions to 0.1 | None |
| `micropython` | openSUSE:Tumbleweed | All versions | 1.28.0-2.1 |

Products: Micropython Micropython.

## How do I fix CVE-2024-8947?

Upgrade to a fixed version.

## Is CVE-2024-8947 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8947 exists.

## Other vulnerabilities in MicroPython

- [CVE-2023-7158](https://insights.sbomify.com/CVE-2023-7158/): MicroPython objslice.c slice_indices heap-based overflow (high 7.3)
- [CVE-2024-8946](https://insights.sbomify.com/CVE-2024-8946/): MicroPython VFS Unmount vfs.c mp_vfs_umount heap-based overflow (medium 6.9)
- [CVE-2024-8948](https://insights.sbomify.com/CVE-2024-8948/): MicroPython objint.c mpz_as_bytes heap-based overflow (medium 6.9)
- [CVE-2023-7152](https://insights.sbomify.com/CVE-2023-7152/): MicroPython modselect.c poll_set_add_fd use after free (medium 5.5)
- [CVE-2026-1998](https://insights.sbomify.com/CVE-2026-1998/): micropython runtime.c mp_import_all memory corruption (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8947 and fix it if it is affected.

What it is: CVE-2024-8947 is a medium-severity use after free vulnerability in MicroPython, published on 17 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8947 exists.

Affected packages and fixed versions:
- micropython-copy (PyPI): affected all versions; no fix listed
- micropython-copy (PyPI): affected all versions up to 3.3.3.post3; no fix listed
- micropython-copy (PyPI): affected all versions up to 3.3.3.post3; no fix listed
- micropython-io (PyPI): affected all versions; no fix listed
- micropython-io (PyPI): affected all versions up to 0.1; no fix listed
- micropython-io (PyPI): affected all versions up to 0.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8947/ (Markdown: https://insights.sbomify.com/CVE-2024-8947/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8947
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8947
- OSV: https://osv.dev/vulnerability/CVE-2024-8947

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8947/
Summaries are generated and may contain mistakes; the official description above is the record.
