CVE-2024-8970 Incorrect Authorization in GitLab

High 8.2 Published Updated

An attacker can trigger CI/CD pipelines as another user, potentially leading to privilege escalation or code execution in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-8970?

CVE-2024-8970 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 11 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 11.6 prior to 17.2.9, starting from 17.3 prior to 17.3.5, and starting from 17.4 prior to 17.4.2, which allows an attacker to trigger a pipeline as another user under certain circumstances.

Weakness: CWE-863

Which versions are affected by CVE-2024-8970?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.6.017.2.9, 17.3.5, 17.4.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-8970?

Upgrade gitlab to a fixed version for your release line: 17.2.9, 17.3.5 or 17.4.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-8970 being exploited?

There is no known exploitation of CVE-2024-8970 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-8970, GHSA-fh2j-rw8g-c7f3, UBUNTU-CVE-2024-8970.

Is CVE-2024-8970 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free