# CVE-2024-8980: Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console

> Remote attackers can execute arbitrary Groovy scripts via CSRF in Liferay Portal Script Console, requiring patching to prevent code execution.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Oct 2024
- **Updated:** 22 Oct 2024
- **Also known as:** GHSA-chj2-4vg7-hhg3

## What is CVE-2024-8980?

CVE-2024-8980 is a critical vulnerability in Liferay Digital Experience Platform, published on 22 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Script Console in Liferay Portal 7.0.0 through 7.4.3.101, and Liferay DXP 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92, 7.3 GA through update 35, 7.2 GA through fix pack 20, 7.1 GA through fix pack 28, 7.0 GA through fix pack 102 and 6.2 GA through fix pack 173
 does not sufficiently protect against Cross-Site Request Forgery (CSRF) attacks, which allows remote attackers to execute arbitrary Groovy script via a crafted URL or a XSS vulnerability.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-8980?

14 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay.portal:release.portal.bom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2023.Q3.1 | 2023.Q3.5 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2023.Q3.1 | 2023.Q3.5 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.0.0-GA to 7.0.10.fp102 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.0.0-GA to 7.0.10.fp102 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.1.0-GA to 7.1.10.fp28 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.1.0-GA to 7.1.10.fp28 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.2.0.GA to 7.2.10.fp20 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.2.0.GA to 7.2.10.fp20 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.3.0-GA | 7.3.10.u36 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.3.0-GA | 7.3.10.u36 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.4.0-GA to 7.4.13.u92 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.4.0-GA to 7.4.13.u92 | None |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.0.0-a1 | 7.4.3.102-GA102 |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.0.0-a1 | 7.4.3.102-GA102 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2024-8980?

Upgrade com.liferay.portal:release.dxp.bom to a fixed version for your release line: 2023.Q3.5 or 7.3.10.u36.

## Is CVE-2024-8980 being exploited?

There is no known exploitation of CVE-2024-8980 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-25145](https://insights.sbomify.com/CVE-2024-25145/): Liferay Portal stored cross-site scripting (XSS) vulnerability (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8980 and fix it if it is affected.

What it is: CVE-2024-8980 is a critical vulnerability in Liferay Digital Experience Platform, published on 22 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-8980 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected from 2023.Q3.1; fixed in 2023.Q3.5
- com.liferay.portal:release.dxp.bom (Maven): affected from 2023.Q3.1; fixed in 2023.Q3.5
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.0.0-GA up to 7.0.10.fp102; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.0.0-GA up to 7.0.10.fp102; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.1.0-GA up to 7.1.10.fp28; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.1.0-GA up to 7.1.10.fp28; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0.GA up to 7.2.10.fp20; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0.GA up to 7.2.10.fp20; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.3.0-GA; fixed in 7.3.10.u36
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.3.0-GA; fixed in 7.3.10.u36
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.4.0-GA up to 7.4.13.u92; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.4.0-GA up to 7.4.13.u92; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8980/ (Markdown: https://insights.sbomify.com/CVE-2024-8980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8980
- OSV: https://osv.dev/vulnerability/CVE-2024-8980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8980/
Summaries are generated and may contain mistakes; the official description above is the record.
