# CVE-2024-8984: Denial of Service (DoS) in berriai/litellm

> Unauthenticated attackers can cause denial of service in LiteLLM by sending HTTP requests with malformed multipart boundaries, exhausting server resources.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-fh2c-86xm-pm2x, PYSEC-2026-1545

## What is CVE-2024-8984?

CVE-2024-8984 is a high-severity denial of service vulnerability in berriai/litellm, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Denial of Service (DoS) vulnerability exists in berriai/litellm version v1.44.5. This vulnerability can be exploited by appending characters, such as dashes (-), to the end of a multipart boundary in an HTTP request. The server continuously processes each character, leading to excessive resource consumption and rendering the service unavailable. The issue is unauthenticated and does not require any user interaction, impacting all users of the service.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-8984?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.56.2 |
| `litellm` | PyPI | All versions | 1.56.2 |
| `litellm` | PyPI | All versions | 1.56.2 |

Products: Litellm Litellm.

## How do I fix CVE-2024-8984?

Upgrade litellm to 1.56.2 or later.

## Is CVE-2024-8984 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8984 exists.

## Other vulnerabilities in berriai/litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-8984 and fix it if it is affected.

What it is: CVE-2024-8984 is a high-severity denial of service vulnerability in berriai/litellm, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-8984 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.56.2
- litellm (PyPI): affected all versions; fixed in 1.56.2
- litellm (PyPI): affected all versions; fixed in 1.56.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-8984/ (Markdown: https://insights.sbomify.com/CVE-2024-8984/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-8984
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-8984
- OSV: https://osv.dev/vulnerability/CVE-2024-8984

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-8984/
Summaries are generated and may contain mistakes; the official description above is the record.
