{"answers":{"affected":"3 open source packages ship an affected version, including pgadmin4. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9014 exists.","fix":"Upgrade pgadmin4 to 8.12 or later.","what":"CVE-2024-9014 is a critical vulnerability in pgadmin.org pgAdmin 4, published on 23 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-9014 and fix it if it is affected.\n\nWhat it is: CVE-2024-9014 is a critical vulnerability in pgadmin.org pgAdmin 4, published on 23 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9014 exists.\n\nAffected packages and fixed versions:\n- pgadmin4 (PyPI): affected all versions; fixed in 8.12\n- pgadmin4 (PyPI): affected all versions; fixed in 8.12\n- pgadmin4 (PyPI): affected all versions; fixed in 8.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-9014/ (Markdown: https://insights.sbomify.com/CVE-2024-9014/index.md)","id":"CVE-2024-9014","markdown":"https://insights.sbomify.com/CVE-2024-9014/index.md","name":"CVE-2024-9014","record":{"aliases":["GHSA-jm9x-rx9x-wpqj","PYSEC-2026-1775"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL management tool","requires_auth":"low_privilege","summary":"Attackers can expose OAuth2 client credentials via the browser, enabling unauthorized access to user data in pgAdmin 4.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"pgadmin_4","vendor":"pgadmin"}],"cvss":{"score":9.9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"pgAdmin versions 8.11 and earlier are vulnerable to a security flaw in OAuth2 authentication. This vulnerability allows an attacker to potentially obtain the client ID and secret, leading to unauthorized access to user data.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2024-09-26","github_poc":2,"max_poc_stars":8,"metasploit":0,"nuclei":1,"refs":[{"date":"2024-09-26T10:34:34Z","kind":"github_poc","ref":"https://github.com/EQSTLab/CVE-2024-9014","stars":8,"title":"Pgadmin4 Sensitive Information Exposure"},{"date":"2025-07-08T11:12:00Z","kind":"github_poc","ref":"https://github.com/r0otk3r/CVE-2024-9014","stars":0,"title":null},{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-9014.yaml","stars":null,"title":"pgAdmin 4 - Authentication Bypass"}],"tier":"weaponised"},"has_fix":true,"headline":"OAuth2 client id and secret exposed through the web browser in pgAdmin 4","id":"CVE-2024-9014","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2024-9015"},"packages":[{"ecosystem":"PyPI","fixed":["8.12"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":null,"source":"GHSA-jm9x-rx9x-wpqj"},{"ecosystem":"PyPI","fixed":["8.12"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"GHSA-jm9x-rx9x-wpqj"},{"ecosystem":"PyPI","fixed":["8.12"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"PYSEC-2026-1775"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2024-9012"},"products":["pgAdmin 4"],"published":"2024-09-23","related":[{"cvss_score":9.9,"headline":"pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment","id":"CVE-2025-2945","kev_date_added":null,"published":"2025-04-03"},{"cvss_score":9.5,"headline":"Deserialization in pgAdmin 4","id":"CVE-2026-12046","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":9.4,"headline":"SQL injection in pgAdmin 4","id":"CVE-2026-17351","kev_date_added":null,"published":"2026-07-31"},{"cvss_score":9.4,"headline":"Command injection in pgAdmin 4","id":"CVE-2026-17566","kev_date_added":null,"published":"2026-07-31"},{"cvss_score":9.4,"headline":"pgAdmin 4: AI Assistant read-only transaction bypass allows unauthorised writes and remote code execution","id":"CVE-2026-12045","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":9.4,"headline":"pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode","id":"CVE-2026-7813","kev_date_added":null,"published":"2026-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-23","vendors":["pgadmin.org"]},"summary":"Attackers can expose OAuth2 client credentials via the browser, enabling unauthorized access to user data in pgAdmin 4.","url":"https://insights.sbomify.com/CVE-2024-9014/"}