# CVE-2024-9014: OAuth2 client id and secret exposed through the web browser in pgAdmin 4

> Attackers can expose OAuth2 client credentials via the browser, enabling unauthorized access to user data in pgAdmin 4.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2024
- **Updated:** 23 Sep 2024
- **Also known as:** GHSA-jm9x-rx9x-wpqj, PYSEC-2026-1775

## What is CVE-2024-9014?

CVE-2024-9014 is a critical vulnerability in pgadmin.org pgAdmin 4, published on 23 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pgAdmin versions 8.11 and earlier are vulnerable to a security flaw in OAuth2 authentication. This vulnerability allows an attacker to potentially obtain the client ID and secret, leading to unauthorized access to user data.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2024-9014?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 8.12 |
| `pgadmin4` | PyPI | All versions | 8.12 |
| `pgadmin4` | PyPI | All versions | 8.12 |

Products: Pgadmin Pgadmin 4.

## How do I fix CVE-2024-9014?

Upgrade pgadmin4 to 8.12 or later.

## Is CVE-2024-9014 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9014 exists.

Public exploit code:

- Pgadmin4 Sensitive Information Exposure (github_poc): https://github.com/EQSTLab/CVE-2024-9014
- https://github.com/r0otk3r/CVE-2024-9014 (github_poc): https://github.com/r0otk3r/CVE-2024-9014
- pgAdmin 4 - Authentication Bypass (nuclei): http/cves/2024/CVE-2024-9014.yaml

## Other vulnerabilities in pgadmin.org pgAdmin 4

- [CVE-2025-2945](https://insights.sbomify.com/CVE-2025-2945/): pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment (critical 9.9)
- [CVE-2026-12046](https://insights.sbomify.com/CVE-2026-12046/): Deserialization in pgAdmin 4 (critical 9.5)
- [CVE-2026-17351](https://insights.sbomify.com/CVE-2026-17351/): SQL injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-17566](https://insights.sbomify.com/CVE-2026-17566/): Command injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-12045](https://insights.sbomify.com/CVE-2026-12045/): pgAdmin 4: AI Assistant read-only transaction bypass allows unauthorised writes and remote code execution (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9014 and fix it if it is affected.

What it is: CVE-2024-9014 is a critical vulnerability in pgadmin.org pgAdmin 4, published on 23 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9014 exists.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 8.12
- pgadmin4 (PyPI): affected all versions; fixed in 8.12
- pgadmin4 (PyPI): affected all versions; fixed in 8.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9014/ (Markdown: https://insights.sbomify.com/CVE-2024-9014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9014
- OSV: https://osv.dev/vulnerability/CVE-2024-9014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9014/
Summaries are generated and may contain mistakes; the official description above is the record.
