CVE-2024-9026 PHP-FPM logs from children may be altered
Attackers can alter or truncate PHP-FPM logs by manipulating output when catch_workers_output or syslog is enabled, compromising log integrity.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-9026?
CVE-2024-9026 is a low-severity vulnerability in Php Php, published on 8 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, when using PHP-FPM SAPI and it is configured to catch workers output through catch_workers_output = yes, it may be possible to pollute the final log or remove up to 4 characters from the log messages by manipulating log message content. Additionally, if PHP-FPM is configured to use syslog output, it may be possible to further remove log data using the same vulnerability.
Which versions are affected by CVE-2024-9026?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
php Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
php-min Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
Products include Php Php.
How do I fix CVE-2024-9026?
Upgrade libphp to a fixed version for your release line: 8.1.30, 8.2.24 or 8.3.12.
Is CVE-2024-9026 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9026 exists.
Other vulnerabilities in Php Php
Sources
Also known as AZL-50144, AZL-50172, BELL-CVE-2024-9026, BIT-libphp-2024-9026, BIT-php-2024-9026, BIT-php-min-2024-9026 and 4 more.