# CVE-2024-9026: PHP-FPM logs from children may be altered

> Attackers can alter or truncate PHP-FPM logs by manipulating output when catch_workers_output or syslog is enabled, compromising log integrity.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-50144, AZL-50172, BELL-CVE-2024-9026, BIT-libphp-2024-9026, BIT-php-2024-9026, BIT-php-min-2024-9026, CLEANSTART-2026-YY93268, DEBIAN-CVE-2024-9026, GHSA-865w-9rf3-2wh5, UBUNTU-CVE-2024-9026

## What is CVE-2024-9026?

CVE-2024-9026 is a low-severity vulnerability in Php Php, published on 8 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, when using PHP-FPM SAPI and it is configured to catch workers output through catch_workers_output = yes, it may be possible to pollute the final log or remove up to 4 characters from the log messages by manipulating log message content. Additionally, if PHP-FPM is configured to use syslog output, it may be possible to further remove log data using the same vulnerability.

Weakness: CWE-158 (Improper Neutralization of Null Byte or NUL Character), CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2024-9026?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
| `php` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |
| `php-min` | Bitnami | All versions | 8.1.30, 8.2.24, 8.3.12 |

Products: Php Php.

## How do I fix CVE-2024-9026?

Upgrade libphp to a fixed version for your release line: 8.1.30, 8.2.24 or 8.3.12.

## Is CVE-2024-9026 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9026 exists.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9026 and fix it if it is affected.

What it is: CVE-2024-9026 is a low-severity vulnerability in Php Php, published on 8 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9026 exists.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12
- php (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12
- php-min (Bitnami): affected all versions; fixed in 8.1.30, 8.2.24, 8.3.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9026/ (Markdown: https://insights.sbomify.com/CVE-2024-9026/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9026
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9026
- OSV: https://osv.dev/vulnerability/CVE-2024-9026

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9026/
Summaries are generated and may contain mistakes; the official description above is the record.
