{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9061 exists.","fix":"No fix has been published for CVE-2024-9061 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-9061 is a high-severity code injection vulnerability in themehunk WP Popup Builder – Popup Forms and Marketing Lead Generation, published on 16 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-9061 and fix it if it is affected.\n\nWhat it is: CVE-2024-9061 is a high-severity code injection vulnerability in themehunk WP Popup Builder – Popup Forms and Marketing Lead Generation, published on 16 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9061 exists.\n\nAffected product: themehunk WP Popup Builder – Popup Forms and Marketing Lead Generation. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-9061/ (Markdown: https://insights.sbomify.com/CVE-2024-9061/index.md)","id":"CVE-2024-9061","markdown":"https://insights.sbomify.com/CVE-2024-9061/index.md","name":"CVE-2024-9061","record":{"aliases":["GHSA-fvv3-x64f-px6p"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary shortcodes in the WP Popup Builder plugin due to improper validation in an AJAX action.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"wp_popup_builder","vendor":"themehunk"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The The WP Popup Builder – Popup Forms and Marketing Lead Generation plugin for WordPress is vulnerable to arbitrary shortcode execution via the wp_ajax_nopriv_shortcode_Api_Add AJAX action in all versions up to, and including, 1.3.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. NOTE: This vulnerability was partially fixed in version 1.3.5 with a nonce check, which effectively prevented access to the affected function. However, version 1.3.6 incorporates the correct authorization check to prevent unauthorized access.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2024-10-16","github_poc":1,"max_poc_stars":3,"metasploit":0,"nuclei":1,"refs":[{"date":"2024-10-16T07:57:48Z","kind":"github_poc","ref":"https://github.com/RandomRobbieBF/CVE-2024-9061","stars":3,"title":"WP Popup Builder – Popup Forms and Marketing Lead Generation \u003c= 1.3.5 - Unauthenticated Arbitrary Shortcode Execution via wp_ajax_nopriv_shortcode_Api_Add"},{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-9061.yaml","stars":null,"title":"WP Popup Builder Popup Forms and Marketing Lead Generation \u003c= 1.3.5 - Arbitrary Shortcode Execution"}],"tier":"weaponised"},"has_fix":null,"headline":"Code injection in WP Popup Builder – Popup Forms and Marketing Lead Generation","id":"CVE-2024-9061","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"macOS Archify: Local Privilege Escalation","id":"CVE-2024-9062"},"packages":[],"prev":{"headline":"AVIF \u0026 SVG Uploader \u003c= 1.1.0 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload","id":"CVE-2024-9060"},"products":["WP Popup Builder – Popup Forms and Marketing Lead Generation"],"published":"2024-10-16","related":[{"cvss_score":6.1,"headline":"WP Popup Builder \u003c 1.2.9 - Reflected Cross-Site Scripting","id":"CVE-2022-2404","kev_date_added":null,"published":"2022-09-26"},{"cvss_score":5.3,"headline":"WordPress WP Popup Builder plugin \u003c= 1.3.8 - Sensitive Data Exposure vulnerability","id":"CVE-2025-62902","kev_date_added":null,"published":"2025-10-27"},{"cvss_score":4.3,"headline":"WP Popup Builder \u003c 1.3.0 - Subscriber+ Arbitrary Popup Deletion","id":"CVE-2022-2405","kev_date_added":null,"published":"2022-09-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["themehunk"]},"summary":"Unauthenticated attackers can execute arbitrary shortcodes in the WP Popup Builder plugin due to improper validation in an AJAX action.","url":"https://insights.sbomify.com/CVE-2024-9061/"}