CVE-2024-9075 Stirling-Tools Stirling-PDF Markdown-to-PDF cross site scripting

Low 2.3 Published Updated

Remote attackers can execute arbitrary scripts via Markdown-to-PDF conversion in Stirling-PDF, requiring high complexity to exploit.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-9075?

CVE-2024-9075 is a low-severity cross-site scripting vulnerability in Stirling-Tools Stirling-PDF, published on 21 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in Stirling-Tools Stirling-PDF up to 0.28.3. It has been declared as problematic. This vulnerability affects unknown code of the component Markdown-to-PDF. The manipulation leads to cross site scripting. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.29.0 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains that "this functionality was removed in 0.29.0 already" and "we plan to re-add at later date with issue resolved".

Weakness: CWE-79

Which versions are affected by CVE-2024-9075?

It affects 1 product.

Products include Stirlingpdf Stirling Pdf.

How do I fix CVE-2024-9075?

No fix has been published for CVE-2024-9075 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-9075 being exploited?

There is no known exploitation of CVE-2024-9075 in the wild and no public exploit code.

Sources

Also known as GHSA-qgcm-qv34-px5h.

Is CVE-2024-9075 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free