{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-9075 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-9075 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-9075 is a low-severity cross-site scripting vulnerability in Stirling-Tools Stirling-PDF, published on 21 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-9075 and fix it if it is affected.\n\nWhat it is: CVE-2024-9075 is a low-severity cross-site scripting vulnerability in Stirling-Tools Stirling-PDF, published on 21 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-9075 in the wild and no public exploit code.\n\nAffected product: Stirling-Tools Stirling-PDF. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-9075/ (Markdown: https://insights.sbomify.com/CVE-2024-9075/index.md)","id":"CVE-2024-9075","markdown":"https://insights.sbomify.com/CVE-2024-9075/index.md","name":"CVE-2024-9075","record":{"aliases":["GHSA-qgcm-qv34-px5h"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Stirling-PDF","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via Markdown-to-PDF conversion in Stirling-PDF, requiring high complexity to exploit.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"stirling_pdf","vendor":"stirlingpdf"}],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Stirling-Tools Stirling-PDF up to 0.28.3. It has been declared as problematic. This vulnerability affects unknown code of the component Markdown-to-PDF. The manipulation leads to cross site scripting. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.29.0 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains that \"this functionality was removed in 0.29.0 already\" and \"we plan to re-add at later date with issue resolved\".","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Stirling-Tools Stirling-PDF Markdown-to-PDF cross site scripting","id":"CVE-2024-9075","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"DedeCMS article_string_mix.php os command injection","id":"CVE-2024-9076"},"packages":[],"prev":{"headline":"Advanced Blocks Pro \u003c= 1.0.0 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload","id":"CVE-2024-9074"},"products":["Stirling-PDF"],"published":"2024-09-21","related":[{"cvss_score":8.6,"headline":"Stirling-PDF SSRF vulnerability on /api/v1/convert/html/pdf","id":"CVE-2025-55150","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":8.6,"headline":"Stirling-PDF SSRF vulnerability on /api/v1/convert/file/pdf","id":"CVE-2025-55151","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":8.6,"headline":"Stirling-PDF SSRF vulnerability on /api/v1/convert/markdown/pdf","id":"CVE-2025-55161","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":7.7,"headline":"Stirling-PDF Server-Side Request Forgery (SSRF)-Induced Arbitrary File Read Vulnerability","id":"CVE-2025-46568","kev_date_added":null,"published":"2025-05-01"},{"cvss_score":3.1,"headline":"Stirling-PDF: Reflected XSS through crafted filename in file upload functionality","id":"CVE-2026-33436","kev_date_added":null,"published":"2026-04-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-23","vendors":["Stirling-Tools"]},"summary":"Remote attackers can execute arbitrary scripts via Markdown-to-PDF conversion in Stirling-PDF, requiring high complexity to exploit.","url":"https://insights.sbomify.com/CVE-2024-9075/"}