CVE-2024-9148 Flowise Stored Cross-Site Scripting

Critical 9.6 Published Updated

Attackers can inject malicious scripts into Flowise Chat Embed, potentially executing code or hijacking user sessions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-9148?

CVE-2024-9148 is a critical cross-site scripting vulnerability in Flowiseai Flowise, published on 24 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.

Weakness: CWE-79

Which versions are affected by CVE-2024-9148?

4 open source packages ship an affected version, including flowise and flowise-embed. It affects 2 products.

PackageAffectedFixed in
flowise npmAll versions2.1.1
flowise npmAll versions2.1.1
flowise-embed npmAll versions2.0.0
flowise-embed npmAll versions2.0.0

Products include Flowiseai Embed, Flowiseai Flowise.

How do I fix CVE-2024-9148?

Upgrade flowise to 2.1.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-9148 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9148 exists.

Sources

Also known as GHSA-m5p9-xvxj-64c8.

Is CVE-2024-9148 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free