{"answers":{"affected":"4 open source packages ship an affected version, including flowise and flowise-embed. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9148 exists.","fix":"Upgrade flowise to 2.1.1 or later.","what":"CVE-2024-9148 is a critical cross-site scripting vulnerability in Flowiseai Flowise, published on 24 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-9148 and fix it if it is affected.\n\nWhat it is: CVE-2024-9148 is a critical cross-site scripting vulnerability in Flowiseai Flowise, published on 24 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9148 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 2.1.1\n- flowise (npm): affected all versions; fixed in 2.1.1\n- flowise-embed (npm): affected all versions; fixed in 2.0.0\n- flowise-embed (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-9148/ (Markdown: https://insights.sbomify.com/CVE-2024-9148/index.md)","id":"CVE-2024-9148","markdown":"https://insights.sbomify.com/CVE-2024-9148/index.md","name":"CVE-2024-9148","record":{"aliases":["GHSA-m5p9-xvxj-64c8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Flowise Chat Embed","requires_auth":"none","summary":"Attackers can inject malicious scripts into Flowise Chat Embed, potentially executing code or hijacking user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"tenable","cpe":[{"product":"embed","vendor":"flowiseai"},{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Flowise \u003c 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed \u003c 2.0.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flowise Stored Cross-Site Scripting","id":"CVE-2024-9148","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"xss","year":"2024"},"n_packages":4,"n_references":1,"next":{"headline":"SQLi in Wind Media's E-Commerce Website Template","id":"CVE-2024-9149"},"packages":[{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-m5p9-xvxj-64c8"},{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-m5p9-xvxj-64c8"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"flowise-embed","purl":null,"source":"GHSA-m5p9-xvxj-64c8"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"flowise-embed","purl":"pkg:npm/flowise-embed","source":"GHSA-m5p9-xvxj-64c8"}],"prev":{"headline":"HTML Injection in Bna Informatics' PosPratik","id":"CVE-2024-9147"},"products":["FlowiseChatEmbed"],"published":"2024-09-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-24","vendors":["FlowiseAI"]},"summary":"Attackers can inject malicious scripts into Flowise Chat Embed, potentially executing code or hijacking user sessions.","url":"https://insights.sbomify.com/CVE-2024-9148/"}