# CVE-2024-9148: Flowise Stored Cross-Site Scripting

> Attackers can inject malicious scripts into Flowise Chat Embed, potentially executing code or hijacking user sessions.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Sep 2024
- **Updated:** 24 Sep 2024
- **Also known as:** GHSA-m5p9-xvxj-64c8

## What is CVE-2024-9148?

CVE-2024-9148 is a critical cross-site scripting vulnerability in Flowiseai Flowise, published on 24 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-9148?

4 open source packages ship an affected version, including flowise and flowise-embed. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 2.1.1 |
| `flowise` | npm | All versions | 2.1.1 |
| `flowise-embed` | npm | All versions | 2.0.0 |
| `flowise-embed` | npm | All versions | 2.0.0 |

Products: Flowiseai Embed, Flowiseai Flowise.

## How do I fix CVE-2024-9148?

Upgrade flowise to 2.1.1 or later.

## Is CVE-2024-9148 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9148 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9148 and fix it if it is affected.

What it is: CVE-2024-9148 is a critical cross-site scripting vulnerability in Flowiseai Flowise, published on 24 Sep 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-9148 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 2.1.1
- flowise (npm): affected all versions; fixed in 2.1.1
- flowise-embed (npm): affected all versions; fixed in 2.0.0
- flowise-embed (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9148/ (Markdown: https://insights.sbomify.com/CVE-2024-9148/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9148
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9148
- OSV: https://osv.dev/vulnerability/CVE-2024-9148

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9148/
Summaries are generated and may contain mistakes; the official description above is the record.
