CVE-2024-9163 User Interface (UI) Misrepresentation of Critical Information in GitLab
An attacker can exploit a business logic error to cause branch name confusion in confidential merge requests, potentially bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-9163?
CVE-2024-9163 is a low-severity vulnerability in Gitlab Gitlab, published on 23 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A business logic error in GitLab CE/EE affecting all versions starting from 12.1 prior to 17.10.7, 17.11 prior to 17.11.3 and 18.0 prior to 18.0.1 where an attacker can cause a branch name confusion in confidential MRs.
Weakness: CWE-451
Which versions are affected by CVE-2024-9163?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.1.0 | 17.11.3, 18.0.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-9163?
Upgrade gitlab to a fixed version for your release line: 17.11.3 or 18.0.1.
Is CVE-2024-9163 being exploited?
There is no known exploitation of CVE-2024-9163 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-9163, GHSA-mqcw-437p-q69q, UBUNTU-CVE-2024-9163.