CVE-2024-9164 Missing Authentication for Critical Function in GitLab
Attackers can execute arbitrary code by running pipelines on unauthorized branches due to missing authentication checks in GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-9164?
CVE-2024-9164 is a critical missing authorization vulnerability in Gitlab Gitlab, published on 11 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in GitLab EE affecting all versions starting from 12.5 prior to 17.2.9, starting from 17.3, prior to 17.3.5, and starting from 17.4 prior to 17.4.2, which allows running pipelines on arbitrary branches.
Weakness: CWE-306
Which versions are affected by CVE-2024-9164?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.5.0 | 17.2.9, 17.3.5, 17.4.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-9164?
Upgrade gitlab to a fixed version for your release line: 17.2.9, 17.3.5 or 17.4.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-9164 being exploited?
There is no known exploitation of CVE-2024-9164 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-9164, GHSA-xc4q-wvjc-4v56, UBUNTU-CVE-2024-9164.