# CVE-2024-9180: Vault Operators in Root Namespace May Elevate Their Privileges

> Privileged Vault operators can escalate privileges to root policy via the identity endpoint, requiring an upgrade to secure the system.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2024
- **Updated:** 8 Nov 2024
- **Also known as:** BIT-openbao-2024-9180, BIT-vault-2024-9180, GHSA-rr8j-7w34-xp5j, GO-2024-3191

## What is CVE-2024-9180?

CVE-2024-9180 is a high-severity vulnerability in Hashicorp Vault, published on 10 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A privileged Vault operator with write permissions to the root namespace’s identity endpoint could escalate their own or another user’s privileges to Vault’s root policy. Fixed in Vault Community Edition 1.18.0 and Vault Enterprise 1.18.0, 1.17.7, 1.16.11, and 1.15.16.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2024-9180?

7 open source packages ship an affected version, including github.com/hashicorp/vault, openbao and vault. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | All versions | 1.18.0 |
| `github.com/hashicorp/vault` | Go | All versions | 1.18.0 |
| `github.com/hashicorp/vault` | Go | All versions | 1.18.0 |
| `openbao` | Bitnami | All versions | 2.0.3 |
| `vault` | Bitnami | From 1.7.7 | 1.18.0 |
| `github.com/openbao/openbao` | Go | All versions | 2.0.3 |
| `github.com/openbao/openbao` | Go | All versions | 2.0.3 |

Products: Hashicorp Vault, Openbao Openbao.

## How do I fix CVE-2024-9180?

Upgrade github.com/hashicorp/vault to 1.18.0 or later.

## Is CVE-2024-9180 being exploited?

There is no known exploitation of CVE-2024-9180 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-9180 and fix it if it is affected.

What it is: CVE-2024-9180 is a high-severity vulnerability in Hashicorp Vault, published on 10 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-9180 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.18.0
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.18.0
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.18.0
- openbao (Bitnami): affected all versions; fixed in 2.0.3
- vault (Bitnami): affected from 1.7.7; fixed in 1.18.0
- github.com/openbao/openbao (Go): affected all versions; fixed in 2.0.3
- github.com/openbao/openbao (Go): affected all versions; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-9180/ (Markdown: https://insights.sbomify.com/CVE-2024-9180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-9180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-9180
- OSV: https://osv.dev/vulnerability/CVE-2024-9180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-9180/
Summaries are generated and may contain mistakes; the official description above is the record.
