{"answers":{"affected":"3 open source packages ship an affected version, including github.com/ubuntu/authd. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-9312 in the wild and no public exploit code.","fix":"Upgrade github.com/ubuntu/authd to 0.3.6 or later.","what":"CVE-2024-9312 is a high-severity vulnerability in Canonical Ltd. Authd, published on 10 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-9312 and fix it if it is affected.\n\nWhat it is: CVE-2024-9312 is a high-severity vulnerability in Canonical Ltd. Authd, published on 10 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-9312 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/ubuntu/authd (Go): affected all versions up to 0.0.0-20230706090440-d8cb2d561419; no fix listed\n- github.com/ubuntu/authd (Go): affected all versions up to 0.0.0-20230706090440-d8cb2d561419; no fix listed\n- github.com/ubuntu/authd (Go): affected all versions; fixed in 0.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-9312/ (Markdown: https://insights.sbomify.com/CVE-2024-9312/index.md)","id":"CVE-2024-9312","markdown":"https://insights.sbomify.com/CVE-2024-9312/index.md","name":"CVE-2024-9312","record":{"aliases":["GHSA-4gfw-wf7c-w6g2","GO-2024-3188"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Canonical Authd","requires_auth":"high_privilege","summary":"A local attacker can spoof user IDs due to insufficient randomization in Authd, allowing them to gain another user's privileges.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"canonical","cpe":[{"product":"authd","vendor":"canonical"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-335","name":"Incorrect Usage of Seeds in Pseudo-Random Number Generator (PRNG)"},{"id":"CWE-286","name":"Incorrect User Management"}],"description":"Authd, through version 0.3.6, did not sufficiently randomize user IDs to prevent collisions. A local attacker who can register user names could spoof another user's ID and gain their privileges.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authd allows attacker-controlled usernames to yield controllable UIDs","id":"CVE-2024-9312","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"PAM module may allow accessing with the credentials of another user","id":"CVE-2024-9313"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":["0.0.0-20230706090440-d8cb2d561419"],"package":"github.com/ubuntu/authd","purl":null,"source":"GHSA-4gfw-wf7c-w6g2"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":["0.0.0-20230706090440-d8cb2d561419"],"package":"github.com/ubuntu/authd","purl":"pkg:golang/github.com/ubuntu/authd","source":"GHSA-4gfw-wf7c-w6g2"},{"ecosystem":"Go","fixed":["0.3.6"],"introduced":["0"],"last_affected":[],"package":"github.com/ubuntu/authd","purl":"pkg:golang/github.com/ubuntu/authd","source":"GO-2024-3188"}],"prev":{"headline":"Cross-Site Request Forgery to XSS in haotian-liu/llava","id":"CVE-2024-9311"},"products":["Authd"],"published":"2024-10-10","related":[{"cvss_score":8.8,"headline":"PAM module may allow accessing with the credentials of another user","id":"CVE-2024-9313","kev_date_added":null,"published":"2024-10-03"},{"cvss_score":8.5,"headline":"Improper Permission Management in SSH Session Handling","id":"CVE-2025-5689","kev_date_added":null,"published":"2025-06-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-10","vendors":["Canonical Ltd."]},"summary":"A local attacker can spoof user IDs due to insufficient randomization in Authd, allowing them to gain another user's privileges.","url":"https://insights.sbomify.com/CVE-2024-9312/"}